Booking.com – Bug in Connectivity system (Internal Reference: ACI-4395) affecting credit card information updates

Incident Report for Hotel Link

Resolved

We are notifying you of a recent, high-priority bug incident that affected credit card information updates from Booking.com. This issue has now been fully resolved.

Incident timeframe:
- Resolved time: 05 December 2025, 13:54:54 (CET)
- Status: Fixed

Impact level:
- Medium
- Specific affected bookings – credit card information was not updated correctly via the API
- Booking.com confirmed a bug affecting credit card information updates

Action required: For affected bookings, properties clients were able to access payment details via the Booking.com extranet

All services are now operating normally.

Thank you for your understanding.
Posted Dec 29, 2025 - 11:46 UTC
This incident affected: API and Channel Distribution.